Eclipse 3.3 : Europe

Bhe oggi ho deciso di aggiornare eclipse (si si quel mattone basato su java) e cosa ottengo un bellissimo stack error:

* run-java-tool is not available for sun-jdk-1.4 on i686
* IMPORTANT: some Java tools are not available on some VMs on some architectures
*** glibc detected *** /opt/phpide/eclipse: double free or corruption (!prev): 0x080721c8 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7af02f7]
/lib/libc.so.6(__libc_free+0x7a)[0xb7af189f]
/opt/phpide/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.0.0.v20070606/eclipse_1017a.so(run+0x81d)[0xb7425665]
/opt/phpide/eclipse[0x80492e7]
/lib/libc.so.6(__libc_start_main+0xdc)[0xb7aa3824]
/opt/phpide/eclipse[0x8048f61]

cercando in rete ho risolto cosi :
[code]
cd /usr/bin
mv run-java-tool run-java-tool.old
ln -s /opt/sun-jdk-1.6.0.01/bin/java run-java-tool
[/code]

mi manca da scoprire cosa è run-java-tool …. pero ora almeno funziona….

EDIT
se facevo link a java si creava un loop!!

UPDATE
che succede è piu veloce?? O_O brr.. fa spavento eclipse ogni aggiornamento dispari merita davvero!!

UPDATE 2
[code]
./eclipse -vm $(java-config –java)
[/code]
è la versione più corretta!!

One Response to “Eclipse 3.3 : Europe”

  1. Schrepfler says:

    Infatti, se vedi il bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=176021 è noto che Europa non funziona “fuori dalla scatola” su gentoo. Io ho già dato il mio voto quando era in milestone ma si vede che eravamo in pochi. Se magari più gente usasse le milestone e i voti magari si sarebbero evitate situazioni come questa.